package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?<sol>.*?)\s*(?<isaret>\<\>|\>=|\>|\<=|\<|\=\=|\!\=)\s*(?<sag>.*?)\s*(?<ayrac>&&|\|\|)*(\s|$)`)
var str = `1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= "52"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}