// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?<sol>.*?)\s*(?<isaret>\<\>|\>=|\>|\<=|\<|\=\=|\!\=)\s*(?<sag>.*?)\s*(?<ayrac>&&|\|\|)*(\s|$)").unwrap();
let string = "1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= \"52\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}