re = /(?<sol>.*?)\s*(?<isaret>\<\>|\>=|\>|\<=|\<|\=\=|\!\=)\s*(?<sag>.*?)\s*(?<ayrac>&&|\|\|)*(\s|$)/mi
str = '1 > 2 && sua== 5 && x >= 9 && v != 25 && b <> 5 && a < 8 && h <= "52"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end