package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+([-+.'].?\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*`)
var str = `global-do-not-reply@abc.com
global-​do-not-reply@abc.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}