re = /\w+([-+.'].?\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*/
str = 'global-do-not-reply@abc.com
global-​do-not-reply@abc.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end