$re = '/\w+([-+.\'].?\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*/';
$str = 'global-do-not-reply@abc.com
global-​do-not-reply@abc.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);