#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![A-Z]{4}[0-9]{2}$).*"
Local $sString = "ASDE12" & @CRLF & _
"asdsa" & @CRLF & _
"dsadsa" & @CRLF & _
"dsadsadsa" & @CRLF & _
"dsa" & @CRLF & _
"ASDE12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")