$re = '/^(?![A-Z]{4}[0-9]{2}$).*/m';
$str = 'ASDE12
asdsa
dsadsa
dsadsadsa
dsa
ASDE12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);