import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![A-Z]{4}[0-9]{2}$).*";
final String string = "ASDE12\n"
+ "asdsa\n"
+ "dsadsa\n"
+ "dsadsadsa\n"
+ "dsa\n"
+ "ASDE12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}