use strict;
my $str = '79001234567
7 900 1234567
7 900 123 45 67
7-900-123-45-67
7 900 123-45-67
7900 123-45-67
7(900)1234567
7 (900) 123 45 67
7 (900) 123-45-67
+79001234567
+7 900 123 45 67
+7 (900) 123-45-67';
my $regex = qr/^\+?\s?7\s?\(?-?(?# code)[0-9]{3}(?# next 3 digit)\s?\)?-?\s?[0-9]{3}\s?-?(?# next 2 digits)[0-9]{2}\s?-?(?# the last 2 digits)[0-9]{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}