$re = '/^(0|[1-9]\d*)(\.(0|[1-9]\d*)){0,3}$/m';
$str = 'Test:
1.0.2
Test:
1.0.3
Test:
10.11
Test:
011
Test:
1.011
The valid numbers are
1
1.23
1.2.53.4
Invalid numbers are
01
1.02.3
.1.2
1.2.
-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);