// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0|[1-9]\d*)(\.(0|[1-9]\d*)){0,3}$").unwrap();
let string = "Test:
1.0.2
Test:
1.0.3
Test:
10.11
Test:
011
Test:
1.011
The valid numbers are
1
1.23
1.2.53.4
Invalid numbers are
01
1.02.3
.1.2
1.2.
-1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}