# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0|[1-9]\d*)(\.(0|[1-9]\d*)){0,3}$"
test_str = ("Test:\n"
"1.0.2\n"
"Test:\n"
"1.0.3\n"
"Test:\n"
"10.11\n"
"Test:\n"
"011\n"
"Test:\n"
"1.011\n"
"The valid numbers are\n"
"1\n"
"1.23\n"
"1.2.53.4\n"
"Invalid numbers are\n"
"01\n"
"1.02.3\n"
".1.2\n"
"1.2.\n"
"-1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.