#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)foo(?!_)"
Local $sString = "Lorem ipsum dolfoo_or sit amet, consecteturfoo ut aliquip ex ea commodo consequat. Duis aute irfooure dolor in reprehenderit in volfoo_uptate velit esse cillum dolore eu sunt in culpa qui officfooia deserunt mollit anim id est laborum"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)