import re
regex = re.compile(r"foo(?!_)", flags=re.MULTILINE)
test_str = "Lorem ipsum dolfoo_or sit amet, consecteturfoo ut aliquip ex ea commodo consequat. Duis aute irfooure dolor in reprehenderit in volfoo_uptate velit esse cillum dolore eu sunt in culpa qui officfooia deserunt mollit anim id est laborum"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)