$re = '/foo(?!_)/m';
$str = 'Lorem ipsum dolfoo_or sit amet, consecteturfoo ut aliquip ex ea commodo consequat. Duis aute irfooure dolor in reprehenderit in volfoo_uptate velit esse cillum dolore eu sunt in culpa qui officfooia deserunt mollit anim id est laborum';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;