const regex = /http(:\/\/7\.beta\.org|s?:\/\/((([123]\.alph|[45]\.bet)a\.com)|6\.(alph|bet)a\.org))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http(:\\\/\\\/7\\.beta\\.org|s?:\\\/\\\/((([123]\\.alph|[45]\\.bet)a\\.com)|6\\.(alph|bet)a\\.org))', 'gm')
const str = `http://1.alpha.com
http://2.alpha.com
http://3.alpha.com
http://4.beta.com
http://5.beta.com
http://6.beta.org
http://7.beta.org
https://1.alpha.com
https://2.alpha.com
https://3.alpha.com
https://4.beta.com
https://5.beta.com
https://6.alpha.org
DO NOT MATCH
http://2.beta.com
https://5.alpha.org`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}