use strict;
my $str = 'http://1.alpha.com
http://2.alpha.com
http://3.alpha.com
http://4.beta.com
http://5.beta.com
http://6.beta.org
http://7.beta.org
https://1.alpha.com
https://2.alpha.com
https://3.alpha.com
https://4.beta.com
https://5.beta.com
https://6.alpha.org
DO NOT MATCH
http://2.beta.com
https://5.alpha.org';
my $regex = qr/http(:\/\/7\.beta\.org|s?:\/\/((([123]\.alph|[45]\.bet)a\.com)|6\.(alph|bet)a\.org))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}