package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z0-9]+`)
var str = `ASD S-DF 2134 4@# 4 234234 #$)(u SD`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}