use strict;
my $str = 'ASD S-DF 2134 4@# 4 234234 #$)(u SD';
my $regex = qr/[^a-zA-Z0-9]+/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";