$re = '/[^a-zA-Z0-9]+/m';
$str = 'ASD S-DF 2134 4@# 4 234234 #$)(u SD';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;