using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^!]\[.+?\]\(.+?\)";
string input = @"Find a [bad link](http://www.google.com) that
[is not](http://www.yahoo.com) an image 
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}