re = /[^!]\[.+?\]\(.+?\)/
str = 'Find a [bad link](http://www.google.com) that
[is not](http://www.yahoo.com) an image 
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end