$re = '/[^!]\[.+?\]\(.+?\)/';
$str = 'Find a [bad link](http://www.google.com) that
[is not](http://www.yahoo.com) an image 
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);