using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_[^\.]+";
string input = @"abc_sg.jpg
gwgwe_234634.png
wglljl_34lklkj.html
中文字_中文字.js
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}