re = /_[^\.]+/m
str = 'abc_sg.jpg
gwgwe_234634.png
wglljl_34lklkj.html
中文字_中文字.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end