$re = '/_[^\.]+/m';
$str = 'abc_sg.jpg
gwgwe_234634.png
wglljl_34lklkj.html
中文字_中文字.js
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);