import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Session: (.+?)[\\n;]";
final String string = "RTSP/1.0 200 OK\n"
+ "CSeq: 3\n"
+ "Server: Ants Rtsp Server/1.0\n"
+ "Date: 21 Oct 2016 15:55:30 GMT\n"
+ "Session: 980603187; timeout=60\n"
+ "Transport: RTP/AVP/TCP;unicast;interleaved=0-1;ssrc=F006B800\n\n"
+ "RTSP/1.0 200 OK\n"
+ "CSeq: 3\n"
+ "Server: Ants Rtsp Server/1.0\n"
+ "Date: 21 Oct 2016 15:55:30 GMT\n"
+ "Session: 980603187\n"
+ "Transport: RTP/AVP/TCP;unicast;interleaved=0-1;ssrc=F006B800";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}