import re
regex = re.compile(r"Session: (.+?)[\n;]")
test_str = ("RTSP/1.0 200 OK\n"
"CSeq: 3\n"
"Server: Ants Rtsp Server/1.0\n"
"Date: 21 Oct 2016 15:55:30 GMT\n"
"Session: 980603187; timeout=60\n"
"Transport: RTP/AVP/TCP;unicast;interleaved=0-1;ssrc=F006B800\n\n"
"RTSP/1.0 200 OK\n"
"CSeq: 3\n"
"Server: Ants Rtsp Server/1.0\n"
"Date: 21 Oct 2016 15:55:30 GMT\n"
"Session: 980603187\n"
"Transport: RTP/AVP/TCP;unicast;interleaved=0-1;ssrc=F006B800")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")