re = /Session: (.+?)[\n;]/
str = 'RTSP/1.0 200 OK
CSeq: 3
Server: Ants Rtsp Server/1.0
Date: 21 Oct 2016 15:55:30 GMT
Session: 980603187; timeout=60
Transport: RTP/AVP/TCP;unicast;interleaved=0-1;ssrc=F006B800
RTSP/1.0 200 OK
CSeq: 3
Server: Ants Rtsp Server/1.0
Date: 21 Oct 2016 15:55:30 GMT
Session: 980603187
Transport: RTP/AVP/TCP;unicast;interleaved=0-1;ssrc=F006B800'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end