#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)"
Local $sString = "Financial Operations (Financing, Customer Payment, and Settlement (AR), Collaborative Financial Processing, Vendor Invoice Verification and Processing (AP),Bank processes and Relationship Management, Allocation of Shared Services), Accounting(Financial statements, General Ledger and Subledger, Revenue and Cost Accounting, Job and Product Accounting, Product and Service Costing ), Corporate Services (Real estate management, Travel management (TEAs), Treasury and finance management ) Human Resource Management (HR Strategy and Planning, Recruitment, Payroll, Compensation and Total Benefits, Employee Development ), Manufacturing and Logistics (Production planning, materials management, inventory management, order entry and processing, warehouse mgmt, transportation mgmt, project mgmt, plant maintenance, customer service mgmt)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")