import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:>[a-zA-z0-9@:. -,-]+))";
final String string = "<title-group>\n"
+ "<title>abcdefghjtshdfg<email>EffectiveHealthCare@ahrq.hhs.gov</email>dfgdfgg</title>\n"
+ "</title-group>\n"
+ "</book-part-meta>\n"
+ "<body>\n"
+ "<p><bold>\n"
+ "<italic>Comparative Effectiveness Review</italic>\n"
+ "</bold></p>\n"
+ "<p><bold>Number 154</bold></p>\n"
+ "<p><bold>Prepared for:</bold></p>\n"
+ "<p>Agency for Healthcare Research and Quality</p>\n"
+ "<p>U.S. Department of Health and Human Services</p>\n"
+ "<p>540 Gaither Road</p>\n"
+ "<p>Rockville, MD 20850</p>\n"
+ "<p><ext-link xlink:href=\"www.ahrq.gov\" ext-link-type=\"uri\">www.ahrq.gov</ext-link></p>\n"
+ "<p><bold>Contract No. 290-2012-00009-I</bold></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}