import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\b[aA][sS][pP])(?<!\\b[vV][bB]|\\b[cC]\\#)\\.[a-zA-Z]{2,6}\\b";
final String string = "asp.net somedomain.com vb.net otherdomain.org wax.museum $%^&.alpha rasp.net ASP.net VB.net C#.az";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}