import re
regex = re.compile(r"(\w+)\/(\w+)(?:\+(\w+))?|(?<!^)\G(?:\s?;\s?(\w+)=([\w\.]+))")
test_str = ("application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello\n\n"
"application/xhtml+json; q=1000; level=4 , \n\n"
"application/ \n"
"q=0.9;\n\n"
"application/;q=3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")