re = /(\w+)\/(\w+)(?:\+(\w+))?|(?<!^)\G(?:\s?;\s?(\w+)=([\w\.]+))/
str = 'application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+json; q=1000; level=4 ,
application/
q=0.9;
application/;q=3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end