re = /\/\* drapeDecalage: (.*?)(?=px \*\/)/
str = 'body {
background: #000;
}
/* drapeDecalage: 10px */'
# Print the match result
str.match(re) do |match|
puts match.to_s
end