package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+((\.)|(\!)|(\?)))`)
var str = `This is test text text test mazafucka. Ololo. Hello world! How are you? Omg...... a!?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}