re = /(\w+((\.)|(\!)|(\?)))/m
str = 'This is test text text test mazafucka. Ololo. Hello world! How are you? Omg...... a!?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end