$re = '/(\w+((\.)|(\!)|(\?)))/m';
$str = 'This is test text text test mazafucka. Ololo. Hello world! How are you? Omg...... a!?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);