using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Product ID:\s*(\d{12})\b";
string input = @"Product ID:
000002183105
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}