const regex = /Product ID:\s*(\d{12})\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Product ID:\\s*(\\d{12})\\b', '')
const str = `Product ID:
000002183105
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}