$re = '/Product ID:\s*(\d{12})\b/';
$str = 'Product ID:
000002183105
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);