using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-][0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?\b";
string input = @"-0.6+3 - 3.0$";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}