package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-][0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?\b`)
var str = `-0.6+3 - 3.0$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}