$re = '/[-][0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?\b/';
$str = '-0.6+3 - 3.0$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);