$re = '/"^((0?[1-9]|1[012])[- .](0?[1-9]|[12][0-9]|3[01])[- .](19|20)?[0-9]{4})*$"/m';
$str = '01-01-2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);