import re
regex = re.compile(r"\"^((0?[1-9]|1[012])[- .](0?[1-9]|[12][0-9]|3[01])[- .](19|20)?[0-9]{4})*$\"", flags=re.MULTILINE)
test_str = "01-01-2019"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")