$re = '/\b[A-Z0-9._%+-]+@([A-Z0-9-]+\.)+[A-Z]{2,}$\b/mi';
$str = 'john@company....co.uk
john@company.co.uk
john@company.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);