// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b[A-Z0-9._%+-]+@([A-Z0-9-]+\.)+[A-Z]{2,}$\b").unwrap();
let string = "john@company....co.uk
john@company.co.uk
john@company.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}