import re
regex = re.compile(r"\b[A-Z0-9._%+-]+@([A-Z0-9-]+\.)+[A-Z]{2,}$\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("john@company....co.uk\n"
"john@company.co.uk\n"
"john@company.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")